Users not able to log in to Later Social

Incident Report for Later

Resolved

We have identified the issue with logins not working on app.later.com, and have resolved the issue! If you have experienced this issue, please try refreshing app.later.com, and signing in again.
Posted Sep 29, 2025 - 16:48 PDT

Investigating

We are currently investigating reports that some users are not able to log in to Later Social (app.later.com) and are getting a "We're sorry, but something went wrong" error. We will update this incident as we learn more. We hope to have this resolved ASAP! Thank you for your patience.
Posted Sep 29, 2025 - 16:41 PDT
This incident affected: app.later.com (General Site, Login/Signup).