Instagram Post and Reel Performance is not available for the previous seven-day period
Incident Report for Later
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 04:54 PDT
Identified
Our teams have identified the root cause of this issue to be an update with how certain data is handled within Later's internal infrastructure. A fix to prevent future occurrences of this behaviour is currently being worked on.

Once this has been completed, more information will be made available here.
Posted Oct 04, 2024 - 08:02 PDT
Investigating
Our teams are currently investigating an issue within Later's Instagram Analytics, specifically with Post and Reel performance, where 'No Data to Display' is appearing when trying to view performance analytics for both Instagram Posts and Reels.

Updates will be shared here as we learn more about the cause of this issue.
Posted Oct 03, 2024 - 09:59 PDT
This incident affected: Social Networks (Instagram).