Mavely accounts are unable to connect to Later Social

Incident Report for Later

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 09:47 PDT

Identified

We are continuing to investigate an issue affecting the ability to connect Mavely accounts to Later Social. Our team has identified the cause and is implementing a fix.
Posted Aug 13, 2026 - 09:12 PDT

Investigating

We are investigating an issue affecting the ability to connect Mavely accounts to Later Social. We will provide updates as they become available.
Posted Aug 13, 2026 - 07:45 PDT