Campaign applications are unable to be submitted

Incident Report for Later

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 13:31 PDT

Monitoring

A fix for this issue has been released across the platform. Our teams are currently monitoring to ensure that all is functioning correctly once again.
Posted Aug 10, 2026 - 13:01 PDT

Investigating

Our teams are aware of and investigating an issue that is impacting the ability to submit campaign applications despite all required fields being completed.

More information will be shared here and at status.later.com as it is available.
Posted Aug 10, 2026 - 11:14 PDT