Users not able to log in to Later.com
Incident Report for Later
Resolved
[Resolved] - Users not able to log in to Later.com
The issue affecting logins to Later.com is now resolved. Our team identified an outage with our login service, which they were able to get resolved - logins and signups to Later.com should now be fully operational. Thank you for your patience and understanding while we worked through this issue. Happy scheduling!
Posted Sep 05, 2024 - 16:32 PDT
Monitoring
Our team was able to identify and release a fix for the issue that was preventing users from logging in to later.com - the issue should be resolved, and we are currently monitoring to ensure the fix fully resolved the issue.
Posted Sep 05, 2024 - 16:20 PDT
Investigating
[Issue] - Users not able to log in to Later.com

We’re currently experiencing an issue with users not being able to log in to Later.com. This will affect users both signing up, and users logging in. Our team is investigating this now. Updates will be available here as soon as we know more. Thank you for your patience - and we hope to have further updates soon.
Posted Sep 05, 2024 - 15:44 PDT
This incident affected: app.later.com (Login/Signup).