Google & Snapchat API Issues

Incident Report for Later

Resolved

Both Google and Cloudflare have resolved this issue!
Posted Jun 12, 2025 - 14:14 PDT

Monitoring

Both Google and Cloudflare has reported their services are recovering, and we're seeing cases where users can refresh/add Snapchat and Google. We are continuing to monitor to ensure that everything is resolved!
Posted Jun 12, 2025 - 13:52 PDT

Investigating

Currently, Cloudflare is experiencing an outage which is affecting the Google and Snapchat API. This issue may prevent Snapchat and YouTube accounts from being added or refreshed within Later. At this time, publishing does not seem affected.

Our team is seeing improvements, and continuing to monitor!

Cloudflare updates can be found here: https://www.cloudflarestatus.com/
Google Status updates can be found here: https://status.cloud.google.com/
Posted Jun 12, 2025 - 11:59 PDT
This incident affected: app.later.com (General Site).