Publishing content and connections between Later and X/Twitter are failing

Incident Report for Later

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 11:00 PDT

Update

X has acknowledged degraded performance across their API and are investigating. We are continuing to monitor for further updates.

More information can be found on X's status page at https://docs.x.com/status
Posted Jun 26, 2025 - 10:40 PDT

Investigating

We are aware of an issue within X's API that is causing connections and posts to fail and are currently monitoring for further information from X.

Any updates will be shared here as made available.
Posted Jun 26, 2025 - 10:20 PDT
This incident affected: Social Networks (Twitter).