YouTube connections are not staying connected within Later

Incident Report for Later

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 17:03 PDT

Monitoring

A fix has been rolled out for refreshing YouTube profile connections and the team is currently monitoring to ensure this fully restores expected behaviour within the platform.
Posted Apr 17, 2025 - 14:47 PDT

Update

Our teams have found the root cause of existing YouTube connections expiring and made changes to ensure these are all refreshed. We are continuing to investigate difficulties with adding new Channels to Later and will share more information as it is available.
Posted Apr 17, 2025 - 13:29 PDT

Investigating

Our teams are aware of an issue with YouTube connections not remaining connected in Later and are currently investigating further. As we learn more, updates will be shared here.
Posted Apr 17, 2025 - 10:45 PDT
This incident affected: app.later.com (Scheduling).