Campaign Application Issue

Incident Report for Later

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 11:48 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 12, 2026 - 11:21 PDT

Identified

We are investigating an issue affecting campaign applications. Our team has identified the cause and is implementing a fix. We anticipate campaign applications to be restored by 3:30pm EST.
Posted Aug 12, 2026 - 11:20 PDT

Investigating

Our team is actively investigating the issue. We are working to identify the root cause and will provide updates as soon as more information becomes available. Thank you for your patience.
Posted Aug 12, 2026 - 09:34 PDT