[Issue] - Connecting to Server
Incident Report for Later
Resolved
The issue affecting our website and app functionality is now resolved. Thank you for your patience and understanding while we worked through this issue.
Posted Sep 27, 2021 - 04:56 PDT
Identified
We've been made aware that our hosting provider has been having some connectivity issues affecting our website and app functionality. Our provider is investigating, and we hope to have an update soon!
Posted Sep 27, 2021 - 03:17 PDT
This incident affected: app.later.com (General Site, Login/Signup).