Twitter Publishing Outage November 2019
Incident Report for Later
Resolved
Twitter's publishing service has returned to a normal error rate. Twitter publishing with Later should work now.
Posted Nov 29, 2019 - 19:00 PST
Monitoring
The Twitter publishing services appears to be improving. Later is monitoring the situation
Posted Nov 29, 2019 - 18:55 PST
Investigating
Twitter currently experiencing an outage with their services.

They are aware of the issues and are working to resolve them. During this time, you may find that Later is affected in the following ways:

1. Twitter posts might fail to publish or result in an error message
Posted Nov 29, 2019 - 18:36 PST
This incident affected: Content Publishing (Twitter Publishing).