X/Twitter's API is continuing to experience degraded performance however we have noted improvements with the ability to refresh profile connections within Later. While the service continues to recover, Later Users may still experience difficulty connecting accounts or refreshing their access to X. More information can be found here: https://docs.x.com/status.
We are continuing to monitor for further improvements and will provide updates here as they are made available.
Posted May 23, 2025 - 13:30 PDT
Monitoring
The X/Twitter API is currently experiencing an outage related to connecting and refreshing accounts. Publishing and analytics are not effected at this time. X/Twitter has acknowledged the issue and our team is monitoring the situation. More information can be found here: https://docs.x.com/status.
We hope to have this resolved soon, and as more information becomes available, we will provide updates here.
Posted May 22, 2025 - 16:54 PDT
This incident affected: Social Networks (Twitter).