Items scheduled to X/Twitter are not publishing as expected.

Incident Report for Later

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 10:54 PDT

Investigating

Our Engineering Teams are aware of an issue with scheduled content not publishing to X/Twitter as expected and are currently investigating the root cause. As more information is made available it will be shared here.
Posted Apr 29, 2025 - 10:33 PDT
This incident affected: app.later.com (Scheduling).