Database Upgrade

Incident Report for Later

Resolved

Our maintenance has been completed! Thanks for your patience
Posted Jan 28, 2022 - 17:59 PST

Identified

Happy Friday Everyone! Later is doing some routine database maintenance this evening and will be back online shortly. Watch here for updates. We shouldn't be down too long.
Posted Jan 28, 2022 - 17:37 PST
This incident affected: app.later.com (General Site).