Twitter/X API is experiencing intermittent issues and outages

Incident Report for Later

Resolved

Twitter/X has advised that the outage with their API has now been resolved. The ability to connect/refresh Twitter/X, and publish posts should now be restored!
Posted May 09, 2025 - 12:14 PDT

Monitoring

We are noticing an improvement in connectivity with X accounts connected to Later and are monitoring for further updates from X's Team. For the most up-to-date information on this issue, please refer to X's Status Page at https://docs.x.com/status#
Posted May 09, 2025 - 11:59 PDT

Identified

The Twitter/X API is currently experiencing an outage, which affects Later's ability to publish Twitter/X posts and connect/refresh Twitter/X accounts.

More information can be found here: https://docs.x.com/status

Our team is working with Twitter/X to get this resolved, and are hoping to have this resolved soon!
Posted May 09, 2025 - 10:35 PDT
This incident affected: app.later.com (Scheduling).