Delayed Publishing: Instagram

Incident Report for Later

Resolved

This incident has been resolved.
Posted Oct 08, 2021 - 14:46 PDT

Investigating

Instagram is currently experiencing technical issues that could cause post failures or delays - we have made them aware and are actively monitoring the situation
Posted Oct 08, 2021 - 12:13 PDT
This incident affected: Social Networks (Instagram).